If you see the following message in your widget: "Your widget needs to be updated", it means your access token to retrieve the photos from your Instagram or Twitter account has expired and needs to be refreshed. This should not happen often, and once it's been refreshed it should not happen again.

To refresh your token, follow these steps:

  1. Log in to your account
  2. Go to your Settings -> Linked Services
  3. If you've already linked the account that you are using for your widget, hover over the account and click the refresh icon. You will then need to sign in with the account again to re-auth your Instagram or Twitter account with SnapWidget. All your widgets using this account will then be updated. Video tutorial: https://youtu.be/ESTZ_1oHRuU
  4. If you have not linked the account yet, hover over the + button, and select Instagram or Twitter to link an account. You will then need to sign in with the account again to re-auth your Instagram or Twitter account with SnapWidget. All your widgets using this account will then be updated. Video tutorial: https://youtu.be/I5snHcu3MJY

All your widgets using that Instagram or Twitter account will now work correctly again. You don't have to update the code snippet on your site.

If you still see the "Your widget needs to be updated" message after following these steps, please try logging in to https://www.instagram.com and revoking access to SnapWidget under Authorized Applications - https://www.instagram.com/accounts/manage_access. 

You can then follow the steps above to re-auth SnapWidget again.

Did this answer your question?